Skip to content

Instantly share code, notes, and snippets.

@samerlahoud
Created December 2, 2012 14:34
Show Gist options
  • Save samerlahoud/4189022 to your computer and use it in GitHub Desktop.
Save samerlahoud/4189022 to your computer and use it in GitHub Desktop.
Openwrt mr-3020 network and wireless config
vi /etc/config/network
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.66'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
list dns '192.168.1.1'
list dns '8.8.8.8'
option ip6addr '2a01:240:fe00:80ab::1/64'
vi /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option macaddr 'f8:d1:11:bd:62:ce'
option hwmode '11ng'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option txpower '27'
option country 'US'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'YYYYY'
option encryption 'psk2'
option key 'XXXXX'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment