Cloud-Init may not create a user literally called admin even though the configuration might be valid.
Log files are available:
cat /var/log/cloud/cloud-init.log
cat /var/log/cloud/cloud-init-output.log
The error one receives from cloud-init module execution
useradd: group admin exists - if you want to add this user to that group, use -g.
It turns out that there already exists an admin group beforehand in GNU/Linux and cloud-init will generally
also create a group according to <username>, in this case admin causing conflicts.
The solution is to let cloud-init know that it shouldn't create an additional group using no_user_group: true
Thank you for this. I spent hours trying to find why i couldn't login to my cloud-init ubuntu vm on proxmox, it's insane..