Last active
July 18, 2023 18:20
-
-
Save skaurus/f2e3a462fa2b97a11d6761538e82371f to your computer and use it in GitHub Desktop.
Setup trick77 dockerflix DNS Proxy on MikroTik RouterOS
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# Setup https://github.com/trick77/dockerflix on Mikrotik router | |
:global portallerHosts " \ | |
ipinfo.io, \ | |
hulu.com, \ | |
netflix.com, \ | |
netflix.net, \ | |
mtv.com, \ | |
mtvnservices.com, \ | |
optimizely.com, \ | |
go.com, \ | |
a248.e.akamai.net, \ | |
video.dl.playstation.net, \ | |
pandora.com, \ | |
uplynk.com, \ | |
crackle.com, \ | |
maxmind.com, \ | |
theplatform.com, \ | |
dramafever.com, \ | |
crunchyroll.com, \ | |
iheart.com, \ | |
brightcove.com, \ | |
logotv.com, \ | |
nbcuni.com, \ | |
nbc.com, \ | |
pbs.org, \ | |
cwtv.com, \ | |
warnerbros.com, \ | |
vevo.com, \ | |
smithsonianchannel.com, \ | |
vh1.com, \ | |
spike.com, \ | |
southpark.cc.com, \ | |
tve_nbc-vh.akamaihd.net, \ | |
sni-vh.akamaihd.net, \ | |
ipad-streaming.cbs.com, \ | |
unicornmedia.com, \ | |
hbogo.com, \ | |
hbonow.com, \ | |
amazon.com, \ | |
dramafevertoken-a.akamaihd.net, \ | |
ulive.com, \ | |
disney.com, \ | |
disneyjunior.com, \ | |
nbcsports.com, \ | |
tvenbcsn-i.akamaihd.net, \ | |
nbcstreameast.nbcsports.com, \ | |
tvegolf-i.akamaihd.net, \ | |
sprtott.*\\\\.akamaihd\\\\.net, \ | |
ftve7300-i.akamaihd.net, \ | |
nflsvgatlgame3-i.akamaihd.net, \ | |
nflioslivesvg2-i.akamaihd.net, \ | |
foxsportshdhls-lh.akamaihd.net, \ | |
beinsportgeolivefs.fplive.net, \ | |
beinsportsconnect.tv, \ | |
beinsportsconnect.net, \ | |
amctv.com" | |
/ip dns static | |
remove [find where comment~"Portaller DNS Proxy"]; | |
:foreach host in=[:toarray $portallerHosts ] do={ | |
:if ($host ~ "\\*") do={ | |
add regexp="$host" address=DOCKERFLIX-SERVER-IP \ | |
comment="Portaller DNS Proxy"; | |
} else={ | |
add name="$host" address=DOCKERFLIX-SERVER-IP \ | |
comment="Portaller DNS Proxy"; | |
} | |
} |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment