-
-
Save tmatth/f2b7c191bf2925e823d3 to your computer and use it in GitHub Desktop.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
<?xml version="1.0" encoding="UTF-8"?> | |
<kcfg xmlns="http://www.kde.org/standards/kcfg/1.0" | |
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" | |
xsi:schemaLocation="http://www.kde.org/standards/kcfg/1.0 | |
http://www.kde.org/standards/kcfg/1.0/kcfg.xsd" > | |
<kcfgfile name="ringconfigrc"/> | |
<!--TODO VoipPreferences is a very bad name--> | |
Let's drop VoipPreferences...this is like the 3rd time that I'm left scratching my head by this. | |
<group name="VoipPreferences"> | |
<entry name="playDtmf" type="Bool"> | |
<label>Play DTMF</label> | |
<tooltip>Play a sound when 0 to 9, A to Z, # and * are pressed</tooltip> | |
<default>true</default> | |
</entry> | |
<entry name="playTones" type="Bool">: true | |
<label>Play room tone</label> | |
<tooltip>Play the buzzzzzzz "room tone" when creating a new call</tooltip> | |
<!-- Ring is a communication platform, not a phone. Therefor, this option | |
is not longer desirable by default | |
--> | |
<default>false</default> | |
</entry> | |
<!--TODO documents --> | |
<entry name="pulseLength" type="Int"> | |
<label></label> | |
<min><!--TODO--></min> | |
<max><!--TODO--></max> | |
<default>250</default> | |
</entry> | |
<!--TODO documents, needed? --> | |
<entry name="symmetric" type="Bool"> | |
<label></label> | |
<default>true</default> | |
</entry> | |
<!--TODO documents, needed? --> | |
<entry name="zidFile" type="Bool"> | |
<label></label> | |
<default>true</default> | |
</entry> | |
</group> | |
<group name="Hooks"> | |
<entry name="iax2Enabled" type="Bool"> | |
<label>Enable IAX2 hooks</label> | |
<default>false</default> | |
</entry> | |
<!--TODO move to client, per group --> | |
<entry name="numberAddPrefix" type="String"> | |
<label>Prefix number</label> | |
<tooltip>Add a prefix in front of the URI before calling</tooltip> | |
<default></default> | |
</entry> | |
<!--TODO documents --> | |
<entry name="sipEnabled" type="Bool"> | |
<label>Enable SIP hooks</label> | |
<default>false</default> | |
</entry> | |
<!--TODO documents --> | |
<entry name="urlCommand" type="String"> | |
<label>Command path</label> | |
<default>x-www-browser</default> | |
</entry> | |
<!--TODO documents --> | |
<entry name="urlSipField" type="String"> | |
<label>SIP header field</label> | |
<default>X-sflphone-url</default> | |
</entry> | |
</group> | |
<group name="Audio"> | |
<!--TODO Move to clients? Incomming vs. outgoing?, group based? --> | |
Not sure if it makes sense to move, it's like autoanswer so maybe... | |
<entry name="alwaysRecording" type="Bool"> | |
<label>Always records calls</label> | |
<default>false</default> | |
</entry> | |
<!--TODO maybe an enum? using the <code> field --> | |
No this should stay a string as audioAPIs can come and go at build time. | |
<entry name="audioApi" type="String"> | |
<label>Audio API</label> | |
<tooltip>Set the default way to access audio</tooltip> | |
<!--TODO use a function as default, in it platform specific --> | |
<default>pulseaudio</default> | |
</entry> | |
<!--TODO unused? --> | |
<entry name="automaticGainControl" type="Bool"> | |
<label>Enable automatic gain control</label> | |
<default>false</default> | |
</entry> | |
<!--TODO should we use "mic", "microphone" or "input device"? --> | |
<entry name="captureMuted" type="Bool"> | |
<label>Mute capture device</label> | |
<tooltip>Mute the microphone</tooltip> | |
<default>false</default> | |
</entry> | |
<!--TODO unused? --> | |
It's used but called noiseSuppress internally in the daemon unfortunately. | |
<entry name="noiseReduce" type="Bool"> | |
<label>Enable noise reduction</label> | |
<default>true</default> | |
</entry> | |
<entry name="playbackMuted" type="Bool"> | |
<label></label> | |
<tooltip>Mute the playback device</tooltip> | |
<default>false</default> | |
</entry> | |
<entry name="recordPath" type="Path"> | |
<label>Recording path</label> | |
<tooltip>Path where the recordings are saved</tooltip> | |
<!--TODO is this a good default? Maybe create a subfolder by default? --> | |
<default><!-- $HOME--></default> | |
</entry> | |
<!--TODO should we use "mic", "microphone", "capture device" or "input device"? --> | |
<entry name="volumeMic" type="Float"> | |
<label>Microphone volume</label> | |
<tooltip>The volume used for the microphone</tooltip> | |
<min>0</min> | |
<max>1</max> | |
<default>1</default> | |
</entry> | |
<!--TODO spkr, speaker, playback device, output device? --> | |
<entry name="volumeSpkr" type="Float"> | |
<label>Playback volume</label> | |
<tooltip>The volume used for the playback device</tooltip> | |
<min>0</min> | |
<max>1</max> | |
<default>1</default> | |
</entry> | |
</group> | |
<group name="Alsa"> | |
<!--TODO should we use "mic", "microphone", "in" or "input device"? --> | |
Input Device | |
<entry name="cardIn" type="Int"> | |
<label>Input device</label> | |
<tooltip>Default microphone device</tooltip> | |
<min>0</min> | |
<default>0</default> | |
</entry> | |
<!--TODO spkr, speaker, playback device, out, output device? --> | |
Output Device | |
<entry name="cardOut" type="Int"> | |
<label>Output device</label> | |
<min>0</min> | |
<default>0</default> | |
</entry> | |
<!--TODO don't use "ring" for ringtone, this will become confusing soon --> | |
<entry name="cardRing" type="Int"> | |
<label>Ringing device</label> | |
<min>0</min> | |
<default>0</default> | |
</entry> | |
<!--TODO documents --> | |
<entry name="plugin" type="String"> | |
<label>Alsa plugin</label> | |
<default>dmix/dsnoop</default> | |
</entry> | |
<!--TODO is the relevant? --> | |
<entry name="smplRate" type="Int"> | |
<label>Sample rate</label> | |
<min><!--TODO 8kHz?--></min> | |
<max><!--TODO 48kHz? --></max> | |
<default>44100</default> | |
</entry> | |
</group> | |
<group name="PulseAudio"> | |
<!--TODO spkr, speaker, playback device, output device? --> | |
<entry name="devicePlayback" type="String"> | |
<label>Playback device</label> | |
<default><!-- Let the daemon pick --></default> | |
</entry> | |
<!--TODO should we use "mic", "microphone" or "input device"? --> | |
Input device | |
<entry name="deviceRecord" type="String"> | |
<label>Input device</label> | |
<default><!-- Let the daemon pick --></default> | |
</entry> | |
<entry name="deviceRingtone" type="String"> | |
<label>Ringing device</label> | |
<default><!-- Let the daemon pick --></default> | |
</entry> | |
</group> | |
</kcfg> |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment