Created
February 2, 2015 20:48
-
-
Save twr14152/4f8893b4db15cc769e6b to your computer and use it in GitHub Desktop.
Week 3 exercise 2
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
service timestamps debug datetime msec localtime show-timezone | |
service timestamps log datetime msec localtime show-timezone | |
! | |
hostname {{item.hostname}} | |
! | |
logging buffered 32000 | |
no logging console | |
enable secret 0 {{item.secret}} | |
! | |
! | |
! | |
! | |
interface FastEthernet0/1 | |
switchport access vlan {{item.access_vlan}} | |
switchport mode access | |
spanning-tree portfast | |
interface FastEthernet0/24 | |
switchport access vlan {{item.access_vlan}} | |
switchport mode access | |
spanning-tree portfast | |
! | |
interface Vlan1 | |
ip address {{item.ip_addr}} 255.255.255.0 | |
no ip route-cache | |
! | |
ip default-gateway {{item.default_gateway}} | |
snmp-server community {{item.snmp_community}} RO | |
! | |
{% if item.SNMP %} | |
access-list 98 remark *** SNMP *** | |
access-list 98 permit any | |
! | |
snmp-server view VIEWSTD iso included | |
snmp-server group READONLY v3 priv read VIEWSTD access 98 | |
snmp-server user pysnmp READONLY v3 auth sha auth_key priv aes 128 encrypt_key | |
{% endif %} | |
line con 0 | |
line vty 0 4 | |
login | |
line vty 5 15 | |
login | |
! | |
! | |
end |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment