Created
February 2, 2015 19:25
-
-
Save twr14152/54ad9ea1f4e6a6e56f93 to your computer and use it in GitHub Desktop.
Week 3 exercise 1 - role/access_switch/templates/access_switch.j2
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
service timestamps debug datetime msec localtime show-timezone | |
service timestamps log datetime msec localtime show-timezone | |
! | |
hostname {{item.hostname}} | |
! | |
logging buffered 32000 | |
no logging console | |
enable secret 0 {{item.secret}} | |
! | |
! | |
! | |
! | |
interface FastEthernet0/1 | |
switchport access vlan {{item.access_vlan}} | |
switchport mode access | |
spanning-tree portfast | |
interface FastEthernet0/24 | |
switchport access vlan {{item.access_vlan}} | |
switchport mode access | |
spanning-tree portfast | |
! | |
interface Vlan1 | |
ip address {{item.ip_addr}} 255.255.255.0 | |
no ip route-cache | |
! | |
ip default-gateway {{item.default_gateway}} | |
snmp-server community {{item.snmp_community}} RO | |
! | |
line con 0 | |
line vty 0 4 | |
login | |
line vty 5 15 | |
login | |
! | |
! | |
end |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment