Last active
August 29, 2015 14:11
-
-
Save vbajpai/55091f8a066717bce9c4 to your computer and use it in GitHub Desktop.
OpenWrt Routed AP configuration
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
OpenWrt:/etc/config$ cat network | |
... | |
config interface 'lan' | |
option ifname 'eth0' | |
option type 'bridge' | |
option proto 'dhcp' | |
config interface 'wwan' | |
option proto 'static' | |
option ipaddr '192.168.1.50' | |
option netmask '255.255.255.0' | |
OpenWrt:/etc/config$ cat wireless | |
config wifi-device 'radio0' | |
... | |
option channel '6' | |
config wifi-iface | |
option device 'radio0' | |
option network 'wwan' | |
option mode 'ap' | |
option ssid '...' | |
option encryption 'psk' | |
option key '...' | |
OpenWrt:/etc/config$ cat dhcp | |
... | |
config dhcp 'lan' | |
... | |
option ignore '1' | |
config dhcp 'wwan' | |
option interface 'wwan' | |
option start '100' | |
option limit '150' | |
option leasetime '12h' | |
OpenWrt:/etc/config$ cat firewall | |
... | |
config zone | |
option name 'lan' | |
option input 'ACCEPT' | |
option output 'ACCEPT' | |
option forward 'ACCEPT' | |
option network 'lan wwan' | |
option masq '1' |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment