Last active
August 29, 2015 14:19
-
-
Save zapdot/10bd29184a2ce765fe0f to your computer and use it in GitHub Desktop.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
using UnityEngine; | |
using System.Collections; | |
public class GoProxyProp<T> | |
{ | |
public T property { get; set; } | |
public GoProxyProp( T startValue ) | |
{ | |
property = startValue; | |
} | |
} |
I think "value" would make more sense, since that what it is returning, not the name of the property being operated on.
I like this. I also think property is appropriate because we then have floatProp and vector2Prop method names.
I think "value" works a bit better too -- since it'd read something like:
GoProxyProp<float> someProgress;
//...
someProgress.value = 5;
Ok I agree with all that. How does this work then for you merging? Is there a way to merge this gist into the pull request? Or do you reject my request, I add this in, and then make a new request? I've not seen anyone make a code gist like this before from a pull request.
You handled it properly, this was just for a side conversation. Thanks!
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Not sure if I'm thrilled with "property" being the actual variable name here. Suggestions welcome.