Skip to content

Instantly share code, notes, and snippets.

@benuski
benuski / compose.yml
Created January 31, 2024 15:50
changedetection.io and browserless v2 docker compose
version: '3.2'
services:
changedetection:
image: ghcr.io/dgtlmoon/changedetection.io:latest
container_name: changedetection
hostname: changedetection
volumes:
- changedetection-data:/datastore
environment:
@iRajatDas
iRajatDas / HowToDeleteAllCloudflareRecors.md
Created November 20, 2022 14:51 — forked from AidasK/HowToDeleteAllCloudflareRecors.md
Cloudflare delete all DNS records. Just go to cloudflare dns zones, open your browers developer console and paste this javascript code.

image

Real developers are not used to clicking, it's allways easier to write a script to do it for you.
@xanderificnl
xanderificnl / mikrotik.md
Created August 21, 2022 14:37
Mikrotik TFTP - netboot.xyz

Be sure to replace the Mikrotik IP & the DHCP network (see line 8, "network set #")

Mikrot IP: 192.168.88.1/24 DHCP network: 0

/tool fetch url="https://boot.netboot.xyz/ipxe/netboot.xyz.kpxe"
/ip tftp add ip-addresses=192.168.88.0/24 req-filename=netboot.xyz.kpxe real-filename=netboot.xyz.kpxe allow=yes read-only=yes
/ip dhcp-server network set 0 next-server=192.168.88.1 boot-file-name=netboot.xyz.kpxe
@narze
narze / gh-add-repos-to-team.sh
Created July 22, 2022 08:33
Add repos to team with gh
#!/bin/bash
PERMISSION="push" # Can be one of: pull, push, admin, maintain, triage
ORG="orgname"
TEAM_SLUG="your-team-slug"
# Get names with `gh repo list orgname`
REPOS=(
"orgname/reponame"
)
@M0r13n
M0r13n / doh
Last active November 16, 2024 17:08
Setup Cloudflare as a DoH (DNS over HTTPS) resolver on Mikrotik devices (RouterOS v7.0.2+)
# Temporarily add a normal upstream DNS resolver
/ip dns set servers=1.1.1.1,1.0.0.1
# CA certificates extracted from Mozilla
/tool fetch url=https://curl.se/ca/cacert.pem
# Import the downloaded ca-store (127 certificates)
/certificate import file-name=cacert.pem passphrase=""
# Set the DoH resolver to cloudflare
@ThomasG77
ThomasG77 / README.md
Last active June 29, 2024 17:29
Recipe to get JSON using pagination using command line tools e.g curl, jq, bc, cat
@z11i
z11i / upload.sh
Last active November 16, 2024 22:05
Use curl to upload a file in a multipart/form-data request, with custom content-type for the file (not the request)
filename='yourfilename'
filetype='text/csv'
token='my oauth token'
url='http://localhost/upload'
curl "$url" \
--form "data=@$filename;type=$filetype" \
--form "name=somename" \
-H "Authorization: Bearer $token"
@cnicodeme
cnicodeme / fixes.md
Last active May 8, 2024 18:03
List of 5,000 Most Frequently Used Domain Name Prefixes and Suffixes - Ordered By Length
@maxivak
maxivak / _0__ssl_certbot_letsencrypt.md
Last active September 21, 2024 18:14
Let's encrypt SSL certificates using certbot in docker

Directories on host machine:

  • /data/certbot/letsencrypt

  • /data/certbot/www

  • Nginx server in docker container

docker run -d --name nginx \
@tannerlinsley
tannerlinsley / README.md
Created July 22, 2020 20:38
Why I still don't use GraphQL

Some thoughts I've gathered over the years on what I think about GraphQL. All of this is subject to change of course, and some of it may be "hot-take"-ish, but at the end of the day, I've made decisions regarding GraphQL with my customers, users, and fellow developers in mind and with the mantra that if it ultimately doesn't make a big difference for any of those people and justify the work that it requires, it's not the best investment of time. It's more important to please your users, ship products in a timely manner, and use tools that keep processes simple and familiar.

  • A majority of the world still runs on REST and probably will for a while.
  • The challenges of larger companies that originally benefitted from GQL are not everyones challenges and they likely never will be.
  • I don't want to require my API users to have knowledge of GQL.
  • Strongly typed APIs are good, but I don't particularly enjoy the tools in the ecosystem right now to use them via GQL
  • GraphQL seems to have been born out of the req