cat /proc/sys/net/bridge/bridge-nf-call-iptables
sysctl vm.swappiness=0
swapoff -a
#include <stdio.h> | |
#include <stdint.h> | |
// Philips Sonicare NFC Head Password calculation by @atc1441 Video manual: https://www.youtube.com/watch?v=EPytrn8i8sc | |
uint16_t CRC16(uint16_t crc, uint8_t *buffer, int len) // Default CRC16 Algo | |
{ | |
while(len--) | |
{ | |
crc ^= *buffer++ << 8; | |
int bits = 0; | |
do |
# Check out the issue for more detail : https://github.com/NationalSecurityAgency/ghidra/issues/2466 | |
# The script will calculate the value of gp register base on the code in entry(), then apply the value to all the functions | |
# This only work in the `RV64I` language though, since other language like `RV64GC` won't set the gp register in entry() | |
from java.math import BigInteger | |
def newAddress(offset): | |
""" | |
Helper function to get a Ghidra Address type | |
""" |
#include <stdint.h> | |
#include <stdio.h> | |
#include <stdlib.h> | |
// munged from https://github.com/simontime/Resead | |
namespace sead | |
{ | |
class Random | |
{ |
This script can be used to backup essential configuration files from the Proxmox Virtual Enivronment (PVE) host.
The script will create backups using tar
with specified backup prefix and date and time stamp in the file name. Script will also delete backups that are older then number of days specified.
To create backup script that will be executed every day we can create backup script in /etc/cron.daily/
folder. We need to make it writeable by root (creator) only, but readable and executable by everyone:
touch /etc/cron.daily/pvehost-backup
# This file contains pin mappings for the Anycubic i3 Mega with | |
# Ultrabase from 2017. (This config may work on an Anycubic i3 Mega v1 | |
# prior to the Ultrabase if you comment out the definition of the | |
# endstop_pin in the stepper_z1 section.) To use this config, the | |
# firmware should be compiled for the AVR atmega2560. | |
# See the example.cfg file for a description of available parameters. | |
[stepper_x] | |
step_pin: PF0 |
import os | |
import sys | |
import time | |
import struct | |
import select | |
import binascii | |
import bluetooth | |
from bluetooth import _bluetooth as bt |
""" | |
Example how to decrypt whatsapp msgstore backups with extension .crypt12. | |
Author: Willem Hengeveld <[email protected]> | |
""" | |
from Crypto.Cipher import AES | |
import zlib | |
import sys | |
datafile = keyfile = None |
# source: https://forum.proxmox.com/threads/removing-deleting-a-created-cluster.18887/ | |
#/bin/sh | |
# stop service | |
systemctl stop pvestatd.service | |
systemctl stop pvedaemon.service | |
systemctl stop pve-cluster.service | |
systemctl stop corosync | |
systemctl stop pve-cluster | |
# edit through sqlite, check, delete, verify |
# jan/29/2018 22: 4:17 by RouterOS 6.41 | |
# | |
/interface list | |
add name=public comment="public network" | |
add name=local comment="local network" | |
add name=guest comment="guest network" | |
# Change the interfaces below to your own | |
/interface list member | |
add list=public interface=ether1 |