Skip to content

Instantly share code, notes, and snippets.

View jamesbrink's full-sized avatar
💭
:trollface:

James Brink jamesbrink

💭
:trollface:
View GitHub Profile
@Roxedus
Roxedus / MAC-xxxxxxxxxxxx.ipxe
Last active November 7, 2024 00:58
Netboot.xyz Talos unattended
#!ipxe
set talos_type controlplane
chain talos-unattended.ipxe
@hermannolafs
hermannolafs / configuration.nix
Last active October 26, 2024 18:49
Nixos Gnome RDP Remote Desktop
{
# minimized for clarity.
# Some of these might not be needed. After some trial and error
# I got this working with these configs.
# I do not have the patience to rn an elimination test.
services.gnome.gnome-remote-desktop.enable = true;
# Enable the X11 windowing system.
services.xserver.enable = true;
@xanderificnl
xanderificnl / mikrotik.md
Created August 21, 2022 14:37
Mikrotik TFTP - netboot.xyz

Be sure to replace the Mikrotik IP & the DHCP network (see line 8, "network set #")

Mikrot IP: 192.168.88.1/24 DHCP network: 0

/tool fetch url="https://boot.netboot.xyz/ipxe/netboot.xyz.kpxe"
/ip tftp add ip-addresses=192.168.88.0/24 req-filename=netboot.xyz.kpxe real-filename=netboot.xyz.kpxe allow=yes read-only=yes
/ip dhcp-server network set 0 next-server=192.168.88.1 boot-file-name=netboot.xyz.kpxe
on: [pull_request]
name: Test
jobs:
test:
runs-on: ubuntu-latest
steps:
- name: Install Go
uses: actions/setup-go@v2
with:
go-version: 1.14.x
@noslin005
noslin005 / BMC and ipmitool.md
Last active January 13, 2024 05:00
Use ipmitool with supermicro boards
  1. Read the fan speed mode:
ipmitool -H <IP> -U <USER> -P <PASSWD> raw 0x30 0x45 0x00

The values are:

  • Standard: 0
  • Full: 1
  • Optimal: 2
  • Heavy IO: 4
@jamesbrink
jamesbrink / README.md
Created July 8, 2019 21:16
DDOS Iptables rules

Aggresive IPTables Rules

echo "service iptables restart"| at now + 2 min

iptables --flush

### Drop invalid packets ### 
iptables -t mangle -A PREROUTING -m conntrack --ctstate INVALID -j DROP
@adam-hanna
adam-hanna / systemd-cloudwatch-logs-tutorial.md
Last active November 6, 2024 08:17
Forward systemd service logs to AWS Cloudwatch

Introduction

I often find myself ssh'ing into my servers and checking my systemd service logs with $ journalctl -f -u {name}.service. One day I got tired of this and wanted all of my important logs in once place (Amazon AWS Cloudwatch). To my dismay, there weren't any real good tutorials on how to do so. So, voilà.

Steps

Overall, it's a fairly simple process consisting of the following few steps.

1. Modify the service file

Open the service file with $ sudo vi /lib/systemd/system/{name}.service

Modify the [Service] section:

@jamesbrink
jamesbrink / patch.patch
Last active July 20, 2019 02:30
the file name is not a typo
From b0a9156259c1ff9f1a0d42a86e08250e37248a0b Mon Sep 17 00:00:00 2001
From: James Brink <[email protected]>
Date: Thu, 27 Dec 2018 04:50:56 -0700
Subject: [PATCH] Updated output_files function to prevent segfault.
I have updated the output_files function in patch.c to gracefully
handle the following scenario.
Given a git style patch like the following.
@Francesco149
Francesco149 / docker-cross-device-link.md
Last active October 27, 2023 08:51
docker error creating new backup file '/var/lib/dpkg/status-old': Invalid cross-device link
In order to work the Bose QC35 Headset Bluetooth do the following:
- sudo pacman -Syu pulseaudio-alsa pulseaudio-bluetooth bluez bluez-libs bluez-utils
- turn off bluetooth from your computer
- sudo btmgmt ssp of
- gpasswd -a YOUR_USER lp