This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
--- | |
- name: Update dat files | |
hosts: all | |
become: yes | |
vars: | |
- base_path: /etc/mosdns | |
- restart_daemon: yes | |
- daemon_service_name: mosdns | |
- clean_up_after: yes |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/interface/veth/add address=172.21.0.201/24 gateway=172.21.0.254 name=veth201 | |
/interface/bridge/port/add bridge=dockers interface=veth201 | |
/container/envs/add name=adguard_envs key=TZ value="Asia/Jerusalem" | |
/container/config/set registry-url=https://registry-1.docker.io tmpdir=usb1-part1/pull | |
/container/mounts/add dst=/opt/adguardhome/conf name=adguardhome_conf src=usb1-part1/adguardhome/conf | |
/container/mounts/add dst=/opt/adguardhome/work name=adguardhome_work src=usb1-part1/adguardhome/work | |
/container/add remote-image=adguard/adguardhome:latest interface=veth201 logging=yes mounts=adguardhome_conf,adguardhome_work root-dir=usb1-part1/adguardhome/root envlist=adguard_envs start-on-boot=yes |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
/system/device-mode/update container=yes | |
/interface veth add address=172.17.0.1/24 gateway=172.17.0.254 name=agh | |
/interface bridge add name=dockers | |
/interface bridge port add bridge=dockers interface=agh | |
/ip address add address=172.17.0.254/24 interface=dockers network=172.17.0.0 | |
/ip firewall nat add action=masquerade chain=srcnat | |
/container config set registry-url=https://registry-1.docker.io tmpdir=/disk1/tmp |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# MONITORING: services run on loopback interface | |
# nginx reverse proxy exposes services to network | |
# - grafana:3010 | |
# - prometheus:3020 | |
# - loki:3030 | |
# - promtail:3031 | |
# prometheus: port 3020 (8020) | |
# | |
services.prometheus = { |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
{ | |
"title": "CapsLock / Control / Tab", | |
"rules": [ | |
{ | |
"description": "Tap CapsLock (⇪) → Escape (⎋); Hold CapsLock (⇪) → Control (⌃)", | |
"manipulators": [ | |
{ | |
"from": { | |
"key_code": "caps_lock", | |
"modifiers": { |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
{ | |
"title": "Switch input source | 输入法切换", | |
"rules": [ | |
{ | |
"description": "Tap Command_L (⌘) → Switch input source to English | 短按左 Command (⌘) → 切换到英文输入法", | |
"manipulators": [ | |
{ | |
"conditions": [ | |
{ | |
"input_sources": [ |