Skip to content

Instantly share code, notes, and snippets.

View mezhgano's full-sized avatar

Dmitry Meshkoff mezhgano

View GitHub Profile
@httpsx
httpsx / WireGuard DPI обход РКН - Windows.md
Last active April 8, 2025 20:28
WireGuard DPI обход РКН - Windows

Для обхода блокировки достаточно отправить 1 любой udp пакет, тем самым нарушим начальное определение протокола WireGuard
Способ с использованием Windows PowerShell. Без скачивания Nmap и подобного софта.

Шаг 0: Отключитесь от всех туннелей.

Шаг 1: Редактируем Клиент конфиг

Добавим в него "ListenPort", это позволит иметь статичный порт на котором будет работать WireGuard
Нажмите ПКМ на нужный "туннель" и выберите "Редактировать выбранный туннель..." Step1

После DNS добавляем новую строку

@zpoint
zpoint / v2ray_wireguard_netflix_spotify_hulu.md
Last active September 19, 2024 07:51
v2ray + wireguard to unblock gfw and netflix,spotify,hulu

I previously write a gist about how to set up v2ray + openvpn to unblock gfw and netflix

Refers to that gist for more detail.

In short, this a solution to proxy your network to bypass Firewall with stable connections, and also unblock Proxy detection for Netflix/Spotify/etc....

In my use case from China network:

wireguard

@slimlime
slimlime / uupdump ConvertConfig.ini explained.md
Created October 8, 2022 22:45
uupdump ConvertConfig.ini explained (convert-UUP, AutoStart, AddUpdates, Cleanup, ResetBase, NetFx3, StartVirtual, wim2esd, wim2swm, SkipISO, SkipWinRE, LCUwinre, UpdtBootFiles, ForceDism, RefESD, SkipEdge, AutoExit, Store_Apps, SkipApps, AppsLevel, CustomList, create_virtual_editions, vAutoStart, vDeleteSource, vPreserve, vwim2esd, vwim2swm, vS…

note: some of the information is posted in comments,
if you'll fork this gist, you'll loose that information,
it is best to just bookmark this one..

WIM

WIM (ESD,SWM) is an image of an OS file system,
it can be mounted, and modified (to some degree) .
there are two possible ways, through DISM or through mounting it directly through an older way, using a driver named imagex (Windows Imaging Utility).
regardless,

terminology

@julianandrews
julianandrews / send-gmail.sh
Created April 22, 2021 16:46
Simple shell script to send email using gmail
# Depends on: msmtp, libsecret-tools
#
# Set password:
# secret-tool store --label="msmtp password for [email protected]" service msmtp username [email protected]
#
# Send mail:
# echo "Message Body" | send-gmail myusername [email protected] "My Subject"
send-gmail() {
local user="$1"
local to="$2"
@tophrr
tophrr / cf-ddns.rsc
Last active September 11, 2024 11:18
Mikrotik RouterOS Cloudflare Dynamic DNS Script
# Cloudflare Dynamic DNS update script
# Required policy: read, write, test, policy
# Add this script to scheduler
# Install DigiCert root CA or disable check-certificate
# Configuration ---------------------------------------------------------------------
:local TOKEN "__APITOKEN__"
:local ZONEID "__ZONEIDENTIFIER__"
:local RECORDID "__RECORDIDENTIFIER__"
:local RECORDNAME "__DNSRECORD__"
@gpchelkin
gpchelkin / shadowsocks-rust-server.sh
Last active March 22, 2025 13:52
How to Setup shadowsocks-rust Server with xray-plugin (like v2ray-plugin) on Any Linux Host
#!/usr/bin/env bash
# https://github.com/shadowsocks/shadowsocks-rust/releases
export SSVERSION=v1.23.0
export SSPORT=443
export SSPASSWORD="CHANGEME"
export SSARCHIVE="shadowsocks-${SSVERSION}.x86_64-unknown-linux-gnu.tar.xz"
#export SSARCHIVE="shadowsocks-${SSVERSION}.aarch64-unknown-linux-gnu.tar.xz"
export PREFIX=/usr/local/bin
@RomelSan
RomelSan / Set up Powerline in PowerShell.md
Last active March 18, 2025 11:31
Set up Powerline in PowerShell
@kabili207
kabili207 / Rclone systemd service.md
Last active April 7, 2025 09:33
Rclone systemd user service

rclone systemd service

Preparation

This service will use the same remote name you specified when using rclone config create. If you haven't done that yet, do so now.

Next, create the mountpoint for your remote. The service uses the location ~/mnt/<remote> by default.

mkdir ~/mnt/dropbox
@lanfon72
lanfon72 / async_ydl.py
Created March 7, 2020 12:19
integrate youtube_dl with asyncio.
import asyncio
from datetime import datetime
from functools import partial
from concurrent.futures import ProcessPoolExecutor
from youtube_dl import YoutubeDL as YDL
PPE = ProcessPoolExecutor()
:if ( [/ping 8.8.8.8 count=5 size=64 interval=2s ] =0) do={
:log error "-----No ping";
/system routerboard usb power-reset duration=2;
:log error "----Reset USB Power";
/delay 30s
:log error "disable";
/interface disable lte1;
/delay 5s
:log error "enable";
/interface enable lte1;