DROP PROCEDURE IF EXISTS sp_delete_users_till_date;
DELIMITER //
CREATE PROCEDURE sp_delete_users_till_date(location_id INT, till_date DATE)
() => { | |
function isDevToolsScript() { | |
var stack = new Error().stack; | |
return stack.includes('devtool'); | |
} | |
Date.prototype.originalGetTime = Date.prototype.getTime; | |
Date.prototype.getTime = function () { | |
if (!isDevToolsScript()) { | |
return this.originalGetTime(); |
# feb/11/2022 11:00:55 by RouterOS 7.2rc3 | |
# software id = 9QK9-C798 | |
# | |
# model = RB5009UG+S+ | |
# serial number = XXXXXXXXXX | |
/ip settings set allow-fast-path=no | |
/interface bridge add admin-mac=FF:FF:FF:FF:FF:FF auto-mac=no name=bridge |
addEventListener('fetch', event => { | |
event.respondWith(handleRequest(event.request)) | |
}) | |
/** | |
* Respond to the request | |
* adapted from https://github.com/xiaoyang-liu-cs/workers-proxy | |
* @param {Request} request | |
*/ | |
async function handleRequest(request) { |
// app-style.js | |
// adding <style></style> directly inside template will result in error or empty element which | |
// this component is trying to address | |
// this will allow you to dynamically insert css inside Vue template without the use of vue loader | |
// or if you do not want to use .vue extension at all | |
// however it doesnt really apply scope css (for now). | |
export default { | |
name: 'app-style', | |
data: function(){ | |
return { |
This focuses on generating the certificates for loading local virtual hosts hosted on your computer, for development only.
Do not use self-signed certificates in production ! For online certificates, use Let's Encrypt instead (tutorial).
Run the following in the terminal:
Install the gcc-7 packages:
sudo apt-get install -y software-properties-common
sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt update
sudo apt install g++-7 -y
Set it up so the symbolic links gcc
, g++
point to the newer version:
notice: Wii U linux is not production ready! Proceed at your own risk. Written on 2/3/18
Quarktheawesome and rw-r-r_0644 have released an early version of Linux for Wii U!
The PowerPC side of the Wii U requires a custom linux kernel, which can be found here. The ARM side of the Wii U requires a custom fw.img file to load that kernel, which can be found here.
Once the kernel is up and running, the first repo is configured to automatically try to load programs from /dev/sda1
in an inserted usb. The first partition of an ext4 USB stick should contain a root filesystem for a linux distribution. See here for more information on a prebuilt PowerPC image
#!/bin/bash | |
# | |
# deboot.sh | |
# script to build Ubuntu rootfs (for arm64, armhf, powerpc, ppc64el) | |
# | |
# Copyright 2017 knotdevel | |
# Released under the MIT license | |
# http://opensource.org/licenses/mit-license.php | |
# | |
# |
/** | |
* You may use this function with both 2 or 3 interval colors for your gradient. | |
* For example, you want to have a gradient between Bootstrap's danger-warning-success colors. | |
*/ | |
function colorGradient(fadeFraction, rgbColor1, rgbColor2, rgbColor3) { | |
var color1 = rgbColor1; | |
var color2 = rgbColor2; | |
var fade = fadeFraction; | |
// Do we have 3 colors for the gradient? Need to adjust the params. |